mercoledì 14 maggio 2008

Joomla 1.5: Inserire video YouTube in un modulo

Mi è stato fatto notare che QTube, il plugin per inserire video YouTube in articoli Joomla! di cui ho parlato un po' di tempo fa, non funziona nei moduli HTML personalizzati (quelli che si creano in Gestione moduli -> Nuovo -> HTML personalizzato).

Questo non è un problema o una limitazione specifica del plugin, ma il modo normale di funzionamento di Joomla 1.5 che non processa i comandi dei content plugin inseriti nel contenuto di moduli HTML.

La possibilità di attivare i mambot su questo tipo di moduli era presente nella versione 1.0 di Joomla, ma questa caratteristica è stata rimossa nella versione 1.5.

Quindi ho creato anche un modulo QTube che può essere utilizzato da chi voglia inserire facilmente un video YouTube in una posizione modulo prevista nel template del proprio sito Joomla.

Il modulo e il plugin funzionano con gli stessi parametri di configurazione (rimando alla documentazione sul sito per i dettagli), ma sono indipendenti e installabili separatamente. Come è ovvio il modulo si configura da Gestione moduli nel backend.

Il tutto, come al solito, lo trovate qui

www.latenight-coding.com/it/joomla-addons/qtube.html

Il plugin è stato anche approvato nella directory delle estensioni del sito ufficiale joomla.org

Ecco il Link

Da questa pagina potete anche votare l'estensione. Se l'avete trovata utile e vi va di spendere qualche secondo, questo è un buon modo per supportarla ed aiutarmi a 'passare parola'.

Già che sono in argomento, colgo l'occassione per fare alcune precisazioni che possono sembrare inutili, ma, a giudicare da alcune richieste di supporto che ho ricevuto, non lo sono. Tutte cose in gran parte scritte nella documentazione del plugin e modulo, ma voglio ripeterle.

1) Il plugin (come tutti i plugin) deve essere attivato da Estensioni -> Gestore plugin nel backend. Se vi ritrovate il comando inserito tra parentesi graffe tale e quale (cioè non rimpiazzato dal video) nel testo dell'articolo, la mancata attivazione del plugin è la causa più probabile del problema.

2) I comandi plugin devono essere inseriti in un articolo. Per inserire un video in una posizione modulo potete usare il modulo QTube di cui ho parlato all'inizio, ma ci sono in ogni caso altri 'posti' dove i plugin non funzionano come i testi descrittivi delle sezioni/categorie ed i componenti: ad esempio non si può utilizzare il plugin per inserire un video in una descrizione prodotto di Virtuemart.

3) Per fare le parentesi graffe che racchiudono il comando (almeno su PC Windows) si usano i tasti AltGr+Maiusc+è e AltGr+Maiusc+* c'è chi ha chiesto anche questo per cui vale la pena rendere l'informazione pubblica se dovesse servire anche ad altri :)

Chiudo qui. Alla prossima.